You are here

LIN Slave | Cypress Semiconductor

LIN Slave

최신 업데이트: 
2020년 12월 18일
버전: 
5.0

특징

기호 도식
  • Full LIN 2.2, 2.1 or 2.0 Slave Node implementation
  • Compliance with ISO 17987 specification
  • Compliance with SAE J2602 specification
  • Compliance with LIN 1.3 specification
  • 완벽한 전송 레이어 지원
  • 자동 보드레이트 동기화
  • 버스 비활성 상태 자동 감지
  • 진단 클래스 I 슬레이브 노드의 완벽한 구현
  • Supports implementation of Diagnostic Class II and III Slave Node
  • 완벽한 오류 감지
  • Automatic configuration services
  • 빠르고 쉬운 구성을 지원하는 커스터마이저
  • Supports import of *.ncf and *.ldf files, export of *.ncf files
  • Editor with syntax checking for *.ncf and *.ldf files

일반적인 설명

The LIN Slave Component implements a LIN 2.2, ISO 17987, and SAE J2602 compliance slave node on PSoC 4 devices. Options for LIN 1.3 and LIN 2.0 compliance are also available. 이 컴포넌트는 LIN 버스에서 통신에 필요한 하드웨어 블록, 그리고 애플리케이션 코드가 LIN 버스 통신과 쉽게 상호 작용할 수 있도록 하는 API로 구성됩니다. The Component provides an API that conforms to the API specified by the ISO 17987 Specification.

The Component provides a good combination of flexibility and ease of use. A comprehensive customizer allows you to easily configure all parameters of the LIN Slave Node. The Component supports both NCF and LDF files to configure the LIN Slave Node.

For PSoC 4 devices only, the LIN Slave Component is certified by the C&S group GmbH based on the standard protocol and data link layer conformance tests. A complete certification report can be made available on request. Contact Cypress Technical Support for details.

PSoC 3 and PSoC 5LP devices are not supported with LIN v5.0. Use the LIN v4.0 Component for these devices.

번역 문서는 참고용으로만 제공하는 것입니다. 설계 과정에 참여할 경우에는 영어 버전 문서를 참고하는 것이 좋습니다.